Technical Requirements


IMPORTANT: All products are English language software and should only be loaded onto English versions of Windows. Our products will not run on a Macintosh unless it has Windows XP or higher loaded or it is running parallels (to find out more about parallels click here.)

Summit Suite Of Software

Recommended

 
Hardware
Intel® Core™ i7-870 2.93 GHz or faster
80 GB hard disk space
4 GB RAM
SVGA or higher resolution monitor (1024 x 768 resolution or higher)
 

Mandatory Operating Environment Components
All Summit products require the following to function correctly:
Windows XP or higher
Access 2002, Access 2003, Access 2003 Runtime, Access 2007, Access 2010 32 bit, Access 2010 32 bit Runtime, Access 2013 32 bit or Access 2015 32 bit
Outlook 2002 or higher

Tested Operating Environments
Windows 2000/Office 2000 (Does not support Summit Central or Summit Event Manager versions above 9.47)
Windows XP/Office 2002 (XP) No Known Issues
Windows XP/Office 2003 No Known Issues
Windows Vista/Office 2007 Refer to Windows registration information and Office 2007 operation information
Windows 7 (64 bit)/Office 2010 (32 bit) Refer to Windows registration information and Office 2010 operation information
Windows 8 (64 bit)/Office 2013 (32 bit) Refer to Windows registration information and Office 2013 operation information
Windows 10 (64 bit)/Office 2010 (32 bit) Refer to Windows registration information and Office 2010 operation information

Summit products are not compatible with 64 bit Office. For Office 2010 and higher, Summit is only compatible with the 32 bit version.

Summit Event Manager Version 11
When released, the base version will be Microsoft Access 2010 32 bit. It will not be available for earlier versions of Access.

Other Recommended Software
WinZip - compression program for faster emailing of event data files
Express ClickYes - assists with individual and broadcast e-mails (Only for Outlook 2003 or earlier)
Win2PDF - enables creation of PDF files of all correspondence


Support Article